Troubleshooting IDE Integrations

Veracode APIs

This section helps you remedy common problems and understand how better to use Veracode IDE integrations.

IDE Integration Issue Solution
Veracode Static for Eclipse I experience a PKIX path building failure when installing the plugin from Eclipse. Add the following lines to the eclipse.ini file in your Eclipse installation directory:
-vmargs
--Djavax.net.ssl.trustStore="path for cacerts"
--Djavax.net.ssl.trustAnchors="path for cacerts"
Veracode Static for Eclipse I cannot install Veracode Static for Eclipse for a new integration.
  1. Ensure you install the latest version of the plugin.
  2. Meet Veracode Static for Eclipse prerequisites.
  3. Ensure your Java version is 1.8 or later.
  4. Provide this information to Veracode Technical Support:
    • Eclipse version. You can find the Eclipse version in Help > Eclipse.
    • Veracode Static for Eclipse plugin version.
    • Screenshots of your errors.
    • Eclipse IDE log. You can find the IDE log in Help > Installation Details > Configuration > View Error Log.
    • The workspace log file in Window > Show View > PDE Runtime > Error Log.
    • Proxy settings screenshot if the issue is with your proxy.
    • Whether this is a user account or API service account.
    • If you are using an API ID and key.
    • The user roles, team membership, and the application name.
Veracode Static for IntelliJ I cannot install Veracode Static for IntelliJ for a new integration.
  1. Ensure you installed the latest version of the plugin. You can check this in Settings > Preferences window > Ctrl+Alt+S > Appearance and Behavior > System Settings > Updates > Check Now.
  2. Meet Veracode Static for IntelliJ prerequisites.
  3. Ensure your Java version is 1.8 or later.
  4. Provide this information to Veracode Technical Support:
    • Logs and Diagnostics Data in a ZIP file.
    • Screenshots of your errors.
    • Whether this is a user account or API service account.
    • If you are using an API ID and key.
    • The user roles, team membership, and the application name.
Maven Build Script This message appears: java.lang.ClassNotFoundException: Cannot find the specified class com.ibm.websphere.ssl The IBM WebSphere environment may prevent a Veracode UploadandScan target from executing if the Maven build script dependencies with the Java class path are missing. To resolve this, generate two pom.xml scripts, using one specifically for the Veracode upload.
Veracode Static for Visual Studio I received a download error that says No applications exist for the specified user's account. Using the Visual Studio Veracode menu, you may have attempted to download results after selecting a specific application for which you do not have permission to access. You must be a member of each team associated with an application to be able to access that application's data.
Veracode Static for Visual Studio The Upload Build menu does not populate the Application dropdown list or allow me to complete the Build text box. This message indicates that you do not have the required role to either create a new application or build.
Veracode Static for Visual Studio I receive this message Support Issue: No precompiled files were found for this ASP.NET web application. Use the Veracode Static for Visual Studio to prepare your .NET application for uploading to Veracode. For information about this extension, see Using Veracode Static for Visual Studio.
Veracode Static for Visual Studio I ran a scan from within Visual Studio, downloaded the scan results and, then, selected Veracode Static > View Results. The Results window is empty. If you are using Visual Studio 2019 with .NET Framework version 4.8, you must clear an option in Visual Studio to ensure the downloaded scan results display in the Results window. Otherwise, the Results window may be empty.

See Configure Visual Studio 2019 to Display Scan Results.

After configuring Visual Studio, you can select Veracode Static > View Results to view the scan results in the Results window.
Veracode Static for Visual Studio Upload and Scan fails to complete automatically. For web applications built on ASP.NET 3.0 Core and later, there is an executable that duplicates the artifacts included in the upload to the Veracode Platform. In your web application project, you must deselect the duplicate executable to exclude it from the upload, or you see an error and the Veracode Platform initiates a manual module selection.
Veracode Static for Visual Studio I need to open a support case with Veracode Technical Support. Provide this information to Veracode Technical Support:
  • Your IDE version.
  • Your Veracode Static for Visual Studio version.
  • If you are scanning at the file level or the project level.
  • The programming language of the application you are trying to scan.
  • The size of the file you are trying to scan.
  • If autoscan is on or off.
  • A list of third-party plugins you use to perform code analysis; for example, "Sonar Lint".
  • Precompilation output. If your application is a web application, then select the Use legacy precompilation method checkbox on the Precompilation page in the Veracode Visual Studio Extension Options.
  • If your application is built with the .NET Core framework, then provide a zipped folder of the Visual Studio log and name your ZIP file in this format: C:\Users\UserName\AppData\Local\Microsoft\VisualStudio\VisualStudioVersion#\Extensions\som efolder\Log\veracode_YYYYMMDD.log. These are the corresponding Visual Studio version numbers: 11 = VS 2012, 12 = VS 2013, 14 = VS 2015, 15 = VS 2017, and 16 = VS 2019. Note that in the Visual Studio log path, the VisualStudioVersion# is in the format of 15.0_8ea552db for Visual Studio 2017 and later, and there may be multiple folders with that format. Because you can do side-by-side installs with Visual Studio 2017 and later, each install creates a new random sequence after the version number.
Veracode Static for Visual Studio I still cannot solve my problem. Reinstall Veracode Static for Visual Studio. Before uninstalling, clear the contents in this folder: C:\Users\UserName\AppData\Local\Microsoft\VisualStudio\

For more uninstall information, see: https://stackoverflow.com/questions/22444799/how-to-uninstall-vsix-visual-studio-extensions.